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Overview 

Where Searches create dynamic SQL (the language used to access the database) based upon your 

input.  SQL stands for Structured Query Language. 

Where searches are available in both the Stockitem and Borrower module, and specific results are 

determined by the user defined criteria.  

The search results can be: 

 Counts  - Displays the number of matching records 

 Query – View the records contained in the query 

 Queried to a File – Performs the query  and saves the result into a file 

Where searches created can also be saved for future use.  
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WHERE SEARCH BASICS 

Accessing Where Search 

You can access Where searches in the Stockitem and Borrower modules by selecting Application > 

Where... (In the Stockitem module) or Application > BorrowerWhere (in the Borrower module) – the 

Where Search screen will display: 

 

Note: There is also a short cut by pressing the Ctrl + W key on the keyboard to open the Where 

search screen. This can be utilised when in the Stockitem or Borrower module. 
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Creating a Where Search 

1. In the Stockitem and Borrower modules by selecting Application > Where... 

2. Choose Search column: it can be helpful to have a look at the main Stockitem (or Borrower) 

screen if you’re confused about which fields contain what information 

3. Choose Search column: it can be helpful to have a look at the main Stockitem (or Borrower) 

screen if you’re confused about which fields contain what information 

OPERATOR DESCRIPTION EXAMPLE 

LIKE Where the required data in this field begins 
with the text entered 

LIKE ELD (for Eldorado) 

LIKE Where the required data in this field does 
not begin with the text entered 

LIKE ELD (for all except Eldorado) 

IN Useful for selecting multiple codes IN A,J,YA (for all of these types) 

IN Useful for multiple codes not to be 
included 

IN ILL,LS (to exclude these types) 

= Where the text entered is exactly equal to 
the data required 

= A (borrowers with a code of A for 
Adult) 

 Where the text entered is not equal to the 
data required 

Useful for NOT EQUAL TO NULL – choose 
this operator, do not enter any data and 
click the Paste button 

 J (borrowers who do not have a code 
of J) 

< Where the text entered is less than the 
data required 

< 01/10/10 (less than 1 Oct 2010) 

< Where the text entered is equal or less 
than the data required 

< 01/10/10 (less than or equal to 1 Oct 
2010) 

> Greater than >01/10/10 (greater than 1 Oct 2010) 

> Equal or greater than the text entered > 01/10/10 (greater than or equal to 1 
Oct 2010) 

4. Type the Where condition: this can be a date, a code, letters, numbers, etc. 

BUTTON DESCRIPTION 

Paste Adds the Where condition to the Query Description table 

Special This button contains useful fields that can be used for any mathematical operand (i.e. , , 

, , , ) – for example: Current Date 

Delete Deletes the highlighted Where condition from the Query Description table 

AND Includes the AND separator to the Where conditions in the Query Description table (this is 
the default) 

OR Includes the OR separator to the Where conditions in the Query Description table 

( Adds a beginning bracket to the Where condition in the Query Description table 

) Adds a closing bracket to the Where condition in the Query Description table 
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Note: 

 If you wanted to find ALL of something (for example: Borrower, StockItem, items on loan) 

then you could run a query such as: 

a. BarCode IS NOT NULL (all Borrowers) 

b. ItemNo IS NOT NULL (all StockItems) 

c. Issue Due Date Back IS NOT NULL (all items on loan) 

 

The NULL value is achieved by simply leaving a blank space in the field 3 Type the Where 

Condition and Press Paste – as soon as the Paste button is clicked a NULL value is entered 

into the Query Description table. 

5. Once your Where condition is set up you can either: 

a. Count the number of results by clicking the F6 Count button: 

 

b. Get the list of results by clicking the F5 Query button: 

 

 

 

 

c. Perform the query and saves the result into a file by clicking the F7 QtoFile button:  
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If a new file is required, click the F1 New button. Type the File Name and select the F3 

Save button. Then to use this new File, ensure the file is highlighted and press the F9 

Select Button. 

Note: If the file already contains data the new records will be added to the file and 

existing data remains. It is possible to empty the content by selecting the F2 Empty 

button. 
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Special Button 

The Special Button contains options, which will change according to the column chosen.  

For example, choosing the column Last Active enables the Report to use a date that is relative to the 

current date. This saves having to add a date each time the report is run. For example to find all 

those borrowers who are over the age of 12. 

The display in the top window will calculate the date in relation to today’s current date. This will 

appear only if the column chosen is a date field. There is an option for Start of the Week and Start of 

the Month. 
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AVAILABE FIELDS IN COLUMN 1 FOR WHERE SEARCHES 

Stockitem 

ITEM NO BOR NAME 

CAT REF NO BOR BARCODE 

TITLE ISSUE LOCATION 

AUTHOR ISSUE DATE ISSUED 

SUBJECT ISSUE DATE DUE BACK 

SERIES ON ORDER 

Publisher RES DATE 

CALL NUMBER LAST CHANGED 

VOL WHO LAST CHANGED 

ED LAST ACTIVE 

STS CODE DATEDUEDDMMYY 

FORM TIMES BORROWED 

CALL SET REFERENCE TIMES RESERVED 

DESCRIPTION TIMES RENEWED 

COPY NO/ CONVERT STOCK TAKE DATE 

LOCATION PERM ORIGINAL COST 

LOCN TEMP LAST DEPR DATE 

FLOOR  MEMO TYPE 

ORIGIN/SOURCE MEMO DATE 

FOR LOAN (Y/N) MEMO END DATE 

LOAN TYPE RES DATE 

OPAC (Y/N) RES STATUS 

ALERT (Y/N) RES STATUS DATE 

PROCESS  RES COLLECT LOCN 

PROCESS DATE RES PLACED LOCN 

RECEIVED  ILL STATUS 

ACCESSIONED ILL STATUS DATE 

CURRENT COST  ILL SUPPLIER ONE 

ILL LIBRARY ILL SUPPLIER TWO 

ILL REN ILL SUPPLIER THREE 

ILL DUE ILL BOR BARCODE 

ITEM TYPE STK HISTORY DATE 

ON LOAN STK HISTORY COMMENTS 

STK HISTORY TYPE GROUP 

STK HISTORY VALUE  
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Borrower 

BARCODE TOTAL # OF VISITS 

PIN TOTAL # OF OPAC VISITS 

SURNAME TOTAL # OF RESERVES 

GIVEN NAME TOTAL # OF RENEWS 

MIDDLE NAME TOTAL # OF LOANS 

TITLE OPERATOR 

SEX LAST CHANGED 

BALANCE AREA CODE 

BIRTHDATE WARD CODE 

TYPE SUBURB CODE 

GROUP POST/ZIP CODE 

CLASS TELEPHONE # 

STATUS MEMO TYPE 

LOCATION MEMO DATE 

REF1 MEMO END DATE 

REF2 ISSUE DATE DUE 

EMAIL ILL STATUS 

USE FOR NOTICES ILL STATUS DATE 

REG EXP. HISTORY DATE 

LAST ACTIVE HISTORY TYPE 

JOINED HISTORY REPORT 

AT  
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SAVING WHERE SEARCHES 

Where searches can be saved to be used at a later stage 

1. In the Stockitem and Borrower modules select Application > Where... 

2. Create the Where search parameter 

3. Click the F2 Insert button – the Saved Queries table will display: 

. 

4. Type in a Description and select the F3 Save button – a prompt will display with the following 

message: The Query File has been created. 

 

5. Click the OK button 

6. Once saved, you can access saved Where searches by clicking the F4 Select button in the 

Where screen, selecting the Saved Query from the list and then clicking the F9 Select button 
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SEARCH SIZES 

The Number of Stock items or Borrowers that display in a Table are dependent on the Search Size 

set. Once the search size has been reached, more items can be seen by selecting the F11 button or 

Table > Continue Query 

Set the Search Size 

1. From the Stockitem menu, select Item > Query Settings > SetSearchSize, from the Borrower 

Details menu, select Borrower > SetSearchSize or from the Catalog menu, select Catalogue > 

SetSearchSize 

 

 

2. The Set Results Search Size screen will display: 

 

3. Select a search size from the list 
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Set the Default Search Size 

The default settings can be changed in the Main > Supervisor > Installation – System tab Default 

search cache size setting 

 

Note: If the Search Sizes are to be set differently for different hours of the day, this can be set in the 

Main > Supervisor> Locations, select the F7NetWK Button. 

 

The F7NetWK option can be used to restrict the number of search results returned at a Location in 

combination with the Hours of the Day. Once this limit is reached, the Continue Query button would 

need to be clicked [F11] continue the search. You are able to restrict search results at busy times for 

example. 

The hours can be selected and the Transmit Quantity either increased or decreased for searches. The 

example shows that at EAS Location, on a Monday, between the Hours of 12pm and 1pm, the 

Searches are restricted to only 200. At other times, it is set by the Installation parameter setting.  
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CREATE REPORTS FROM A TABLE  

Once the Where Search has been queried into a table, it is possible to print a report from the 

resulting Table. 

1. In the Stockitem List (or Borrower List), select: Table > Report F7 – the List Reports screen 

will display: 

 

2. Select a specific style – for example: Author, Title, Call No and Form 

3. Click the F9 Order button to select the sequence in which the items display – for example: 

Title, Call No. etc. 

4. Use the Caption box to add a heading to your report – for example: Weeding List 

5. Click the F8 View button to display the report 

 

6. The print button can then be used to print the report 
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STOCKWAND CHANGE 

This facility is used to define a set of changes and apply those changes to all items: 

 Individually from the Barcode (select Start and begin wanding the Item Numbers) [F6] 

 From a File [F7]  

 From a Saved Where Search [F8] 

Setting Values to Change 

1. Launch the Amlib Client 

2. Go to Main > StockItems> StockWandChange – the Stockitem Wand Change screen will 

display 

3. Choose the Column to Change box 1: select a parameter – for example: Process 

4. Type the new Value into box 2 

Please Note: A list of codes can be accessed from box 2 by entering a full stop and pressing the Tab 

key on your keyboard. The Special button can be used for assigning Date ranges using the Current 

Date which can be very useful. 

 

5. Click the Paste Button 

6. The values to change will display in the Columns at the base of the screen 
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Executing the Changes 

The changes can be applied in one of 3 methods: 

Individually from the Barcode: 

a) Click the F6 Start button – the Start prompt will display containing a confirmation 

message: 

 

b) To proceed, click the Yes button 

c) Begin wanding the Items into the Item No field for the changes to be applied 

From a Saved File: 

d) Click the F7 FrFile button – the Stockitem Saved Query Results screen will display 

e) Highlight the relevant File (saved previously) and click the F9 Select button – the Mass 

Change from file prompt will display with the number of items to change defined as 

well as the File selected: 

 

f) Review the message and if the information is correct click the Yes button to proceed 

g) A prompt with the following message will display when complete:  

The XX Stockitems have been Updated 
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From a Saved Where Search: 

h) Select the F8  FrWhere button – the Saved Queries  screen will display 

i) Highlight the relevant saved Where Search (Saved previously) and click the F9 Execute 

button – the Mass Change from Saved Where prompt will display with the number of 

items to change defined as well as the Where Search selected: 

 

j) Review the message and if the information is correct click the Yes button to proceed 

k) A prompt with the following message will display when complete: 

 The XX Stockitems have been Updated 
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Saving a StockWandChange  

A Stockwand Change can be saved for future use: 

1. With the Stockwand Change parameters displayed click the F2 Insert button – the Saved 

Stock Wand Changes screen will display: 

 

2. Type a Description in the field at the bottom of the screen 

3. Click the F3 Save button 

 

Reusing a StockWandChange set of Parameters 

1. Go to Main > StockItems> StockWandChange – the Stockitem Wand Change screen will 

display 

2. Click the F4 Select button – the Saved Stock Wand Changes screen will display 

3. Highlight the required StockWand Change 

4. Click the F9 Select button 

5. The parameters will display where the items can be selected by wanding, from a File or from 

a Saved Where search 
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BORROWER CHANGES 

Borrower changes can be made globally by: 

 Import from an Administration system via a Borrower Import 

 Changes from an Administration SQLServer database using Borrower Online Change 

 Borrower Where searches to files for Mass changes 

 Report for Borrower change using the More buttons 

Where Search to Files can be useful for both Public Libraries and Schools to Query the database for 

Borrowers who need to be changed e.g. For Juniors who need to be changed to Young Adult and for 

Students who need to be changed to different Year Groups and Classes.  

If a school does not import changes from an Administration system e.g. MAZE, changes from one 

year and one class to another can take place using Where Searches and Mass change. 

 

Mass Borrower Change 

This process can be used to change Borrower Group, Type, Class, etc. The example used here is 

Borrower Group.  

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerWhere – the Borrower Where screen will display 

3. Create a Where clause – for example: Group = CHI (this will search for all Borrowers who are 

in that particular group) 

a. Highlight the field to search on: Group 

b. Choose Operator: = 

c. Enter the Where condition, or the exact data you want to find – for example: CHI 

d. Click the Paste button to insert the clause into the table 
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4. Click on the F7 QtoFile button – the Borrower Saved Query Results screen will now display: 

 

5. Click on the F1 New button to create a new Saved File 

6. Type in a name for the file in the Details column – for example: Groups to Change 

7. Click on F3 Save button 

8. Highlight the new Saved File and click on the F9 Select button to save results to this file 
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9. A prompt will display noting the number of borrowers contained in the file 

 

10. Click the OK button 

11. Go to Main > Borrowers > Borrower – the Borrower screen will display 

12. Select File > DisplayFile – the Borrower Saved Query Results file screen will display 

   

13. Highlight the required Saved File and click on the F9 Select button to display the file 

14. From the Borrowers List screen, select Table > Mass Borrower Change 
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6. The Mass Change of Borrowers within a File screen will display: 

 

7. Enter the following settings: 

a) Select the field you wish to change for all stockitems in the file example -  Group 

b) Type in the new value example, which is what you are changing all stockitems to be – for 
example: DUT 

c) Click on the Paste button to insert the new criteria into the bottom table 

d) Click on the F3 Update button to start the mass change 

e) This will change all the Borrower Groups in this file so that they are now Dutch 
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MASS DELETE 

Stockitems and Borrower can be deleted “en masse” by creating a table of Stockitems or Borrowers.  

Stockitem 

1. From the Stockitem or Borrower screen, perform a query from a relevant field or wand into a 

file. 

2. From a resulting table, select the Stockitems to be deleted by highlighting the rows. To 

highlight more than one Stockitem, press the Control key and click with the left mouse 

button 

3. From the Table menu, select Table > MassItemDelete. You will be given the option to receive 

a confirmation at each deletion: 

 

 No: All items highlighted in the table will be deleted, unless the item is on loan, has 

reservations or memos. If the Stockitem is the last for the catalogue, the catalogue will also 

be deleted. No messages display. 

 Yes: Each item’s ID will display. Messages will also display if the item cannot be deleted (e.g. 

the item is on loan, has reservations or memos). 

 Cancel: No deletion will take place. You will be returned to the Table View. 

Borrower 

Borrowers can also be deleted from a Table. In the Table View, highlight all the Borrowers in the 

Table.  From the Table menu, select Table > Mass Borrower Deletion. 

A dialogue box will display, requesting whether confirmation messages are required each time a 

Borrower is to be deleted. 

 
 

Note: Any Borrower who has items on loan, reservations or memos cannot be deleted until the 

loans, reservations or memos are deleted. 
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APPENDICES 

Appendix 1: Sample Where Searches 

Stockitem 

All Stockitems  

a) Item No IS NOT NULL 

All Stockitems at a certain location 

a) Perm Loc = LIB 

All Stockitems with a particular Stats code e.g. to get a tally of all Adult Fiction items 

a) Sts Code = AF (Type Stats Code) 

All Junior Items 

a) Sts Code LIKE J 

All Stockitems with a particular Form code e.g. to get a tally of all Videos. 

a) Form = VID 

All Stockitems at a particular Location 

a) Location Perm = EAS (Location Code) 

Add PermLoc to set it to just Videos at a Location or a Stats code to get just Fiction Videos 

a) Form = VID 

b) Sts LIKE F 

Missing items, with a Process Date of more than 6 months 

a) Process LIKE MIS (Type beginning of process code) 

b) Process Date < Current Date – 6 months (via Special button) – this can be altered to suit your 

particular needs 

Items where cost is over $500 

a) Current Cost > 500 

Items with no cost 

a) Current Cost = 0 or Current Cost IS NULL 
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Items never borrowed 

a) Times Borrowed = 0 

Items borrowed more than 50 times 

a) Times Borrowed > 50 

Items that do not have a valid barcode 

a) Item No NOT LIKE 36450 (or whatever the beginning of the barcode is) 

Items that should appear in an account, for example between 28 and 35 days overdue 

a) DateDueDDMMYY > Current Date – 5 Weeks (via Special button) 

b) IssueDateDuBack < Current Date  – 4 Weeks (via Special button) 

Issues on a certain day 

Useful to find all items issued on a certain day 

a) Issue Date Issued = 07/03/2012 (Type the date into column 3 and press Paste) 

All Items with Memo Type of RESRET 

a) MemoType = RESRET 

Claimed Returns 

a) MemoType LIKE Claim 

Call No Ranges (e.g. Art books to change for a weekly loan for a short period of time) 

a) Call Number >  700 

b) Call Number < 760 

c) Form = BK  

Items overdue by 3 months e.g. Ready to use for Accounts 

A Shelf check could also be done based on a report printed in Call No order from the resulting table. 

a) IssueDateDeuBack < Current Date – 3 months (via Special button) 

Items without Catalogue records 

a) Cat Ref No IS NOT NULL 
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Select F6Count for a quick count of the Stockitems without Catalogue. This could then be 

modified to indicate for example, those items which are not Periodicals, or just Books. 

InterLibrary Loans not received yet 

a) Item No LIKE ILL 

InterLibrary Loans not available for renewal 

a) ILL Ren = N 

Items with more than 3 reserves 

a) Res > 3 

Items not available for loan 

a) For Loan (Y/N) = N 

Items with an Item Type of Master (M) 

For those sites that are set up as a Master and have Subsidiary items attached. For example a kit or a 

Video with Multiple programs 

a) Item Type = M 

Items on loan at present 

a) Issue Date IS NOT Null 

Items e.g. Videos available i.e. Not on loan 

a) Issue Date IS NOT Null 

b) Form = VID 

Items that have been received within a certain period e.g. last financial year etc. 

a) Received > 01/07/2012 

b) Received < 01/07/2013 

 

Items not active since a certain date or period e.g. within the last 12 months 

a) Last Active < Current Date – 12 months 
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Items that have an edition date to check  

For Libraries who show the publishing date in the Stockitem Edition Field. For example Items 

published prior to 1980 

a) Ed < 1980 

These can then be checked from a Table e.g. To see if there could be dubious content e.g. Science 

based books 

Reserved items are to be collected at other than the Reserve placed location 

a) Res Collect Locn ≠ Res Placed Locn 

Items with a Memo but do not have a Memo Type 

a) Memo Type IS NULL 

b) Memo Date > 0 

Reservations Printed more than two weeks ago 

a) Res Status LIKE PR 

b) Res Status Date < Current Date – 2 Weeks 
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Borrower 

All Borrowers 

a) Barcode IS NOT NULL 

All Year 7s 

a) Type = Y07  

All juniors active in the last 2 years 

(Useful in setting up and saving for SLOWA statistics for Public Libraries – do this for Juniors, Adults)  

a) Type = J 

b) Last Active > Current Date – 2 years 

All Adults active in the last 2 Years  

(Useful in setting up and saving for SLOWA statistics for Public Libraries – do this for Juniors, Adults)  

a) Type IN YA,A,HB,ST 

b) Last Active > Current Date – 2 years 

All Young Adults 

Not all Public Libraries use the code of Young Adult and include them in either Juniors or Young 

Adults 

a) Type = YA 

All Students (not Staff) 

a) Type IN T,N,A (Whatever your codes are staff e.g. Teacher, Non Teacher, Admin) 

All Institutions 

Check to see how these have been set up at the Library 

a) Type IN E,SCH,ILL 

Borrowers with Memos 

a) Memo Date > 0 

Claimed Returns 

a) Memo Type LIKE CLAIM 
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Borrowers who have lost their card 

a) Status = LC (Whatever your status code is) 

Borrowers with Financials 

a) Owing > 0 

Borrowers who have joined e.g. in the last 3 months 

a) Joined > Current Date – 3months  

Borrowers who have overdue 

a) Issue Date Due < Current Date 

Borrowers not active for a year (or 3 years) etc. 

a) Last Active < Current Date – 3 years 

Borrowers who have never borrowed 

a) Total # of Loans = 0 

Borrowers whose registration has expired 

a) Reg Exp. < Current Date 

Accounts sent in this month 

a) History Type LIKE ACC 

b) History Date > Start of Month 

Borrowers with Email addresses 

a) Bor Email > 0 

Borrowers who live locally in the district 

a) Post/Zip Code IN 6017,6018,6019 (or appropriate Postcode for the district) 

Borrowers who DO NOT live locally in the district 

a) Post/Zip Code IN 6017,6018,6019 (or appropriate Postcode for the district) 
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Appendix 2: Other Useful Reports 

Borrower 

Borrower Counts including Borrower Type and Location:  &bct.qrp  or for schools &bctsch.qrp 

 Count by Borrower Type and Location 

 Count by Borrower Gender and Type 

 Count by Borrower Suburb and Location   

 School report includes Class as well. 

Where parameters could be: 
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MS Excel Report - Counts by Borrower Type: &xbct.qrp 

 

 

 

Automatic Borrower Field Update: &BORUPD.QRP 

The Automatic Borrower Field Update enables mass changing of Borrower Types, Classes, Groups 

and Status’ through the Report module. Details are changed through the [F10] More page. 

You are able to change more than one area at once by adding these to the [F10] More page, each 

area to change will need a new Report Line Number (e.g. 1, 2, 3 or 4). The Column field determines 

which field you wish to change (T = Types, C = Classes, G = Groups and S = Status’). The New Value 

column features the changed data. There is also an option to attach a system generated memo to 

the Borrower record, the text for this is determined via the Text for Letter button on the 

RepBorrower screen. 

  

The above screens show a way of changing the status of a Borrower who owes $50+ into Banned.  

Another use would be to change a Junior member into an Adult member when they turn 18. The 

More statement would list – Report Line: 1, Column: T, New Value: A, Send Memo: Y (The Text for 

Letter could say to Recheck address details and get borrower to resign acceptance of library rules). 

The Where statement would list – BorType = J AND BirthDate <= CurrentDate – 18 years.  The memo 

generated will have a type of AUTOUPDATE.  
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Value of the Collection 

Count by Form, Stats: &stkcfs.qrp 
 

 
 

High Usage 

There are 3 new report templates to count Stockitem usage within a time period specified with the 

‘where’ statement. The report templates are designed to show items used more than 5, 10 or 20 

times within a specified period. The report templates will list the title and the number of times used 

within the specified period. 

 &STKH5.QRP - Shows items where count > 5 

 &STKH10.QRP - Shows items where count > 10 

 &STKH20.QRP - Shows items where count > 20 

The reports are run against the Stock History table. Users that delete data from the Stock History 

table need to be aware of the limitations of results. 

1. Set up the report in Stockitem Reports 

 

2. Set up the F7Where search parameter  
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3. Set up the F9Order (NOTE: MUST SORT BY Item No) 

 

Sample Report 
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Location, Title, # No of items, Author Call No, Form &stkltn.qrp 

Useful when listing multiple items e.g. Reading collections 
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Statistics  

The Statistics that Amlib collect are selected from the Stats Params table, in Amlib navigate to Main > 

Supervisor > StatsParams. You may change descriptions and collection flags for any of these items 

but you may not alter the intrinsic value of a code i.e. 05 is always an issue even though you may give 

it a description of “loan” rather than “issue” The issue program has been set to add 1 to the 05 code 

set every time an issue is made.  

 

The report names themselves will give you an indication of the report order parameters. The report 

template will explain the contents of the report.  

TEMPLATE CODES 

 &STAT1 – Summary by Year, Form 

 &STAT2 – Summary by Year, Month 

 &STAT3 – Summary by Year, Month, Day 

 &STAT4 – Summary by Year, Month, Day, Hour 

 &STAT5 – Details by Borrower Type 

 &STAT6 – Count by Location, Type, Borrower 

 &STAC – Location, Borrower Class, Form 

 &STAG – Location, Borrower Group, Form 

 

 

 

 

 

 

 

 



Where Search Training  

 

 

Last Updated:  26 February 2013 
 Page 38 

Where Parameters 

These are set accordingly to the date range required. For example, just for the Month, for the 

Financial Year, for a Calendar Year etc. 

 To set the dates for a Financial Year (e.g. 2002/2003 Financial Year) 

 

 For a Calendar Year 

 

 

 For a month  
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 For several months e.g. a Quarter the Operator IN could be used e.g. January, February, and 

March of 2003. 

 

 

 

Design Statistics Report 

These depend on what format the report is to be displayed. Some examples are below: 

Sample Statistics Reports 

Counts – These can be gathered by Saved Where Searches (e.g. Stockitem/Item/Saved Where 

Searches) or from the Report Module - e.g. Borrower Counts or Stockitem Counts 

 

Summary of the Total for all Statistics on the system (e.g. Total ILLs) 

 

 Details: Sort by Location, Stats Type (Iss,Ret), Year  - &stat101.qrp  

 

 Details: Sort by Location, Type (Iss,Ret), Stats Code  (Loans by Stats Code only) - &stat620.qrp 
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Other Useful Statistics 

 Summary by Month order by Location, Type (Iss, Ret), Year, Month: &stats200.qrp 

 

 Details by Location, Statistical Type, Borrower and Stats Code: stat520.qrp  
 

 

 Details by Location, Statistical Type, Stats Code & Form Code: &stat526.qrp  
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Daily Stats 

A useful report that shows the activity for the week by the hour is &stat4i.qrp. This will display the 

activity, showing hours and totals for each day. 

 

 

Once your Statistics Reports are set correctly, each time you then run the report in the future it is 

just a simple matter of altering the Where parameters for the current Month or current Financial 

year etc., Viewing, and Printing! 

 

 Summary by Location, TransType, Year (&xstat10.qrp), Summary by Location,TransType, 

Year, Month, Day: &xstat30.qrp  

 Details by Location, TransType, BorType, ItemForm: &xstat50.qrp 

 Summary by Location, TransType, Year, Month: &xstat20.qrp 



 

 

Appendix 3: Sample Date Line   
 

(When using the Special Button) 
 

For example:  To create a report to extract data between the month 1st and 3rd month. 
 

 

 

 

 
 

 
 

 

 

 

 

 

 

 

 

 

 

1 2 3 4 



  
21
 
14  

    

Months 

 

 0 

+ 

≤ ≥

≥ 

− 
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OPERATORS 

For Reports & 

Where 

Searches 

LIKE LIKE IN IN =  < < > > F12 

Begins 

with 

 

 

 

Does not 

begin 

with 

Include 

these 

multiple 

codes 

e.g. J,A 

Do not 

Include 

these 

multiple  

codes 

Equal 

to… 

Not Equal 

to… 

Less than Less than 

or Equal 

to 

Greater 

than 

Greater 

than or 

Equal to 

PRINT 

SCREEN 

 


